Blog

Home   /   blog   /   Cara Membatasi Bandwidth Video Streaming dengan Mikrotik

Cara Membatasi Bandwidth Video Streaming dengan Mikrotik

Berikut ini cara yang cukup efektif untuk membatasi penggunaan bandwidth untuk situs-situs yang meng-embed video streaming semacam Youtube, Dailymotion, Metacafe, Tube8, dan lain-lainnya dengan menggunakan Mikrotik.

Skenarionya adalah mendeteksi konten web yang meng-embed video streaming dengan menggunakan layer 7 protocol, lalu menandai paket-paket datanya, dan membatasi penggunaan bandwidthnya dengan simple queue.

Langkah Pertama, tambahkan filter video content pada Layer 7 di mikrotik dengan perintah :

/ip firewall layer7-protocol add name=http-video regexp="http/(0.9|1.0|1.1)[x09-x0d ][1-5][0-9][0-9][x09-x0d -~]*(content-type: video)"

 

Langkah Kedua, membuat mangle untuk menandai paket video streaming dengan perintah :

/ip firewall mangle add action=mark-packet chain=prerouting comment="http-video mark-packet" disabled=no layer7-protocol=http-video new-packet-mark=http-video passthrough=no

 

Langkah Terakhir, menambahkan aturan pembatasan bandwidth untuk video streaming pada simple queue (pada contoh ini batas download video streaming adalah 64kbps), perintahnya  :

/queue simple add max-limit=0/64000 name=http-video packet-marks=http-video

Leave a Reply

Your email address will not be published. Required fields are marked *